Friday, May 04, 2012

Internets...Broken...Must

Must...Struggle on...

C'mon, AT&T, try to at least fake it. 1.34 Mbps is not "high speed DSL." You might as well just mail me screengrabs!

We ate the last packet this morning, after a final, forlorn ping came staggering in from Illinois. The RJ45s are rattling like castinets, loose in their sockets. The Cat6 was withered down to Cat4 last time I dared look. Will we escape from this vast wasteland before it hits Cat-nil, rotting cloth-covered UTP flapping broken and bleached under the merciless sun?

Save yourself! The providers have dumped us here to live or die, and it's every modem for itself!

8 comments:

Tam said...

Oh dear! :(

Frank W. James said...

Up here in the hinterlands (the remote flatlands of corn, beans and windmills) I would KILL for 1.34mps and YES I AM paying for 'High Speed' DSL!!!...

All The Best,
Frank W. James

Tango Juliet said...

Gonna get 10MBS cable here next week in the middle of nowhere (or pretty darn close to it.)

Nathan said...

I was just thinking that back in November 2002, 1.5Mbps DSL was smokin'.

We are all so spoiled.

Popgun said...

Such lovely snark!

Just got Exede12 about a month ago; ten times faster than Hughesnet. Finally!

-Popgun

North said...

Cat-astrophe.

Dave H said...

Can you try a different modem? My cable internet went to heck over the last year (down to about 250 kbps, should have been 10 Mbps), and after their phone support folks said "when can we send out a tech?" I figured I'd just drop it. (I wasn't in a position to take time off of work to wait fo the tech.) But I chanced $30 on a cable modem on eBay and it works great now.

Anonymous said...

It may depend on your power source, where I am we use a converted treadle operated sewing machine, want speed, treadle faster. Have fun. Good Luck